We are currently experiencing delays in the delivery of gift cards to recipients in Ukraine

Incident Report for HiThrive

Update

We're continuing to work with our fulfillment partners to resolve this issue and get outstanding orders processed.
Posted Dec 24, 2025 - 14:21 EST

Identified

Some gift card orders for brands in Ukraine are taking longer than usual to be delivered. This may impact both digital delivery times and redemption availability for certain brands.

Our team is actively working with our fulfillment partners to monitor the situation and restore normal delivery timelines as quickly as possible.
Posted Dec 23, 2025 - 09:07 EST
This incident affects: HiThrive.