Service has been fully restored. Users should be able to access HiThrive using Slack, Microsoft Teams and the web app normally. We'll continue to monitor the platform.
Posted Jun 12, 2025 - 16:18 EDT
Update
Services are beginning to come back online as Google Cloud works to resolve their outage. Users may still have trouble accessing HiThrive via Slack, Microsoft Teams and our web app. Automated celebrations and HRIS syncing are functioning normally again.
Posted Jun 12, 2025 - 15:33 EDT
Update
Google Cloud has acknowledged a global platform-wide outage affecting many of their products. We'll continue to monitor our platform and update this ticket once the issue is resolved.
Posted Jun 12, 2025 - 15:04 EDT
Investigating
We are currently investigating an platform-wide outage due to multiple regions on Google Cloud Platform being completely unavailable.